wyDay blog  |  Downloads  |  Buy
Support forum
wyDay blog
wyDay Home

wyUpdate failed (when password present but disabled)Answered

This is my first time using wyUpdate and I'm sure I'm doing something wrong. I'm getting the following error when trying to update my application.

Entry updtdetails.udt uses an unsupported compression method (0x63, Unknown (0x0063))

Any advice?

Aug 25, '12permalink

My guess is the update files is being corrupted either when it's being uploaded or downloaded.

First, try rebuilding your updates. Then re-upload them to your server. Then retry running wyUpdate.

Are you running IIS? If so, have you changed the extension of the update & server files (e.g. .wys and *.wyu)?

Aug 26, '12permalink

I've already tried this about 5 times and still the same issue. No I'm not running IIS.

Aug 26, '12permalink

What version of wyUpdate.exe are you running? What server software are you using?

Try to enable update signing. (Rebuild wyUpdate to get the latest wyUpdate.exe and client.wyc with the new sign key in it). The Rebuild your updates, reupload them, and retry using wyUpdate.

Tell me if you get a different error or the same one.

If that doesn't work then I'll have to see your files.

Aug 26, '12permalink

I'm still getting the same error. Please let me know what you would like me to send you and where.


Aug 26, '12permalink

One last question: You're not password protecting your updates, are you? (File -> Properties -> Update & server files -> Is "Encrypt using password" checked?)

Aug 26, '12permalink

I was at the beginning and then i removed it.see pichttp://i47.tinypic.com/16az7kz.jpg

Aug 26, '12permalink

Have you rebuilt your updates and reuploaded them to your server since you've disabled encryption?

Also, have you rebuilt wyUpdate and used the new client.wyc and wyUpdate.exe to check for updates?

Also, it sounds like you're using an old version (or custom built version) of wyUpdate.exe. Right click wyUpdate.exe, click Properties, then click Details. What version is listed.

Aug 26, '12permalink

I went ahead deleted and recreated the project and now its working. I will try to replicate the issue later and let you know the steps to do so.

Aug 26, '12permalink

We've found the problem. This will be fixed in the next version of wyBuild (coming late Monday, early Tuesday).

Aug 26, '12permalink


On which version has this issue resolved?We using version V2.6.18.4, but this version was the password issue not resolved.

Oct 1, '12permalink

I'll look into this.

Oct 1, '12permalink

I'm getting this error now. Everything has been working fine since day one but now this error pops up. I have a password set and it is checked to use a password. Did you ever find out the exact reason for the error so I can avoid doing what I did to break it?

Aug 26, '13permalink

I switched to .Net 2.0 and the error went away. The issue is with .Net 4 when there is a password.

Aug 26, '13permalink

Any eta when the .net4 using a password for compression bug will be fixed?

Aug 27, '13permalink

It will be fixed with the upcoming release.

Aug 29, '13permalink
Aug 29, '13permalink

I am also awaiting this fix. any idea what the ETA is on the upcoming release?


Sep 9, '13permalink

Until now, I've been using wyupdate with autoupdater since 2012 without issue.  I started getting this error today (2022-01-12).  

I started using password/encryption as soon as it became available, as our use case is one that required it to pass audit.  I have tried it both encrypted and unencrypted and I see the same issue, yes I have rebuilt, and re-uploaded numerous times, disabled A/V, etc. following suggestions from this and other threads.

I am attempting to use the .net 4 version as I will need tls 1.3 soon.  I've even pulled the repository and stepped through the code.  The _CompressionMethod_FromZipFile  being returned from the file is not enumerated in ZipEntry.CompressionMethod, but it is int value 99.

Jan 12permalink

We're dropping support for password protected update files in the next release. It's security through obscurity (and it's not even that obscure).

If you want to limit access to updates, do it like so: https://wyday.com/wybuild/help/limit-updates.php

Jan 12permalink