Downloads  |  Buy

Can't link both TurboActivate and TurboFloat static libraries on Windows

Can't link both TurboActivate and TurboFloat static libraries on Windows

Postby bkendall » September 27th, 2019, 3:09 pm

I'm unable to link to both the TurboActivate and TurboFloat static libraries on Windows.

I'm using the latest versions of both libraries, v4.1.9.0.

I'm compiling on Windows 7 64-bit and am using the 64-bit native command line tools included with Visual Studio 2017. I've double checked to make sure I'm using the x64 versions of the static libraries that are compatible with VS2017 and VS2019.

When compiling, I get the following linker errors: https://pastebin.com/PubGkuQG

This looks like it might be the same issue that two other users mentioned in an unrelated thread:

https://wyday.com/forum/viewtopic.php?f=3&t=28139&p=46907#p47995
https://wyday.com/forum/viewtopic.php?f=3&t=28139&p=46907#p48013
bkendall
 
Posts: 5
Joined: February 16th, 2019, 1:42 pm

Re: Can't link both TurboActivate and TurboFloat static libraries on Windows

Postby Wyatt » October 1st, 2019, 9:20 pm

Interesting. We’ll look into this for the next bug fix version. It’s not a priority right now (other releases coming first). In the meantime, on Windows use the dynamic libraries.
User avatar
Wyatt
Site Admin
 
Posts: 6092
Joined: July 11th, 2007, 10:30 pm
Location: New Hampshire


Return to LimeLM, TurboActivate, & TurboFloat Support