Downloads  |  Buy

Minimum curl version [Solved]

Minimum curl version [Solved]

Postby shounakb » September 19th, 2019, 6:52 am

What is the minimum curl version required by the latest version of TurboActivate. Until now I used an older version of TurboActivate.a as soon as i replaced it with a newer one I started getting curl errors.
For eg.
libTurboActivate.a(libcurl_la-urlapi.o): In function `curl_url_set':
urlapi.c:(.text.curl_url_set+0x303): undefined reference to `__mb_sb_limit'
urlapi.c:(.text.curl_url_set+0x30a): undefined reference to `_CurrentRuneLocale'
urlapi.c:(.text.curl_url_set+0x369): undefined reference to `_ThreadRuneLocale'
urlapi.c:(.text.curl_url_set+0x388): undefined reference to `_DefaultRuneLocale'
urlapi.c:(.text.curl_url_set+0x3aa): undefined reference to `_ThreadRuneLocale'
urlapi.c:(.text.curl_url_set+0x3c9): undefined reference to `_DefaultRuneLocale'

Curl version installed on my system - 7.29.0
Any ideas ? What i might be doing wrong ?
shounakb
 
Posts: 11
Joined: August 20th, 2018, 2:17 am

Re: Minimum curl version

Postby Wyatt » September 19th, 2019, 8:01 am

On Linux, BSD, and Windows TurboActivate includes all the necessary dependencies (including libCurl) built-in.

The errors you're getting are related to the old compiler you're using. On Linux use at least gcc 8.0. We no longer support old versions of compilers for the static libraries.

If you're stuck on old compilers use the dynamic library.
User avatar
Wyatt
Site Admin
 
Posts: 6092
Joined: July 11th, 2007, 10:30 pm
Location: New Hampshire

Re: Minimum curl version [Solved]

Postby shounakb » September 20th, 2019, 12:59 am

Hi,

Thanks for your reply. I replaced the static library with the dynamic one, and it solved my issue. Thanks a lot.
shounakb
 
Posts: 11
Joined: August 20th, 2018, 2:17 am


Return to LimeLM, TurboActivate, & TurboFloat Support