Downloads  |  Buy

cloud flating server

cloud flating server

Postby pengbo » June 28th, 2020, 5:00 am

Hi, with this pricing: https://wyday.com/limelm/signup/, does the floating server is hosted by wyday or we must host it by myself?

Our requirements:
1. Support cloud floating license and offline activation license
2. Support both Windows, Linux , should be 64bit (windows 10, Windows server 2008, 2012, 2016, 2018, Debian 9 and higher, Ubutnun 16.04 or higher, CentOS 7.5 or higher), in the future, also need support Linux on ARM 64
3. We use C++ with the VS2017/GCC8.3, and static link with the boost 1.72, but I see in the library folder, your libraries use boost 1.73 with VC14.1, I believe our boost version is VC14.2, and we must use static link, how to solve this problem? And our application is already linked with libcurl, does this conflicts with your curllib.lib ?
4. Does your solution support docker environment?

Currently are use another license provider, but not good, we would like to switch to your solution, please help, thanks.
pengbo
 

Re: cloud flating server

Postby Wyatt » June 29th, 2020, 9:29 am

>> "Hi, with this pricing: https://wyday.com/limelm/signup/, does the floating server is hosted by wyday or we must host it by myself?"

The TurboFloat Server must (currently) be hosted by you or your customer. Covered extensively in the TurboFloat Server article: https://wyday.com/limelm/help/turbofloat-server/

We will offer hosted TurboFloat Server instance. No hard date. ASAP. It'll be announced on our blog when it's released (subscribe the blog RSS if you want to be notified).


>> "3. We use C++ with the VS2017/GCC8.3, and static link with the boost 1.72, but I see in the library folder, your libraries use boost 1.73 with VC14.1, I believe our boost version is VC14.2, and we must use static link, how to solve this problem? And our application is already linked with libcurl, does this conflicts with your curllib.lib ?"

Use our libs or use the dynamic version of TA / TF. Don't swap out our static library dependencies -- you *will* get crashes and undefined behavior. It's guaranteed.

So, if you can't use our static libraries, use our dynamic libraries.


>> "4. Does your solution support docker environment?"

Yes, TA, TF can be used in Virtual machines (docker is just a crummy VM). However, we always recommend using TF in VMs: https://wyday.com/limelm/help/vm-hypervisor-licensing/
User avatar
Wyatt
Site Admin
 
Posts: 6425
Joined: July 11th, 2007, 10:30 pm
Location: New Hampshire


Return to LimeLM, TurboActivate, & TurboFloat Support